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Using Siemens NX 11 Software 

 

Advanced Finite Element Analysis - Valve 

1 – Introduction. 

 

The goal of this tutorial is to perform a finite element analysis (FEA) of a water flow running 

through a pipe which is heated. 

 

 Make a copy of the file C:\Commun\NX \fem\valve.prt file in your local folder, and open it. 

2 – Reset dialog boxes. 

 

  Click on Menu->Preferences->User Interface... 

 In the User Interface Preferences dialog box, click on the Options item of the left tree, and 

then on the Reset Dialog Memory button. 

 Click OK to validate. 
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3 – Creating a new FEM file. 

 

 Create a new FEM file by clicking on File->New and selecting under the Simulation tab 

of the New dialog box, the item Simcenter Thermal Flow (FEM). 

 In the New FEM dialog box, set the option Analysis Type of the Solver Environment 

field to Coupled Thermal-Flow. 

In what follows, we will perform the next couples of steps 

 

1. Creating meshes (2D and 3D) and their associated material properties for defining how 

the water and the pipe will behave under geometric and thermal constraints. 

2. Applying boundary conditions, loads and couplings. 

3. Computing the FEA. 

4. Visualizing the results. 
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4 – Meshes and associated material properties. 

 In the tree of the Simulation Navigator , click on the + symbol in front of the 

Polygon Geometry item . 

 You can see two Polygon Body objects. Rename the first one Water (click-right on 

it->Rename) and the second one Pipe. The first object will model the fluid (water), while 

the second object will model the pipe through which the water is running. 

 
 You can hide/show these objects by clicking on their respective checkboxes . 

 Select the Pipe and assign to it the 

material 

Aluminium_2014. 

 Select the Water and assign to it the 

material Water. 

 Select the Water and click on the 

3D-Tetrahedral button. In 

the 3D tetrahedral Mesh dialog box, 

select the TET4 mesh type with an 

element size of 10 mm. 

 In the Destination Collector field 

click on the New Collector 

button. A collector associates a 

mesh with a material. 

 In the Mesh Collector dialog box, set 

the Name option to Water, choose 

Water as material, and uncheck the 

Radiation checkbox. 

 Click OK  to return to the previous 

dialog box, and then click OK again. 

 The 3D mesh associated to the 

material properties of water should 

be created. 
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 Select the Pipe and click on the 2D Mesh 

button. 

 In the 2D Mesh dialog box, select the 

TRI3 Thin Shell element type with an 

element size of 10 mm. 

 In the Destination Collector field, click on 

the New Collector button. 

 In the Mesh Collector dialog box, select 

Aluminium_2014 as Material. 

 In the Physical Property field, click on the 

Create Physical button. This will set 

the behavior of the thin shell along the 

third dimension. 

 In the Thin Shell dialog box, go to the 

Thickness field and set the Thickness 

option to 2 mm (thickness of the pipe). 

 Click OK to return to the Mesh Collector 

dialog box. 

 In the Thermo-Optical Properties 

field, set the Radiation option to 

None. 

 Set the Name option to Pipe. 

 Click OK to return to the 2D 

Mesh dialog box, and then click 

OK again. 

 A 2D mesh associated to the 

material properties of aluminium 

(thin shell) should be created. 

 Save your files (ctrl+s). 
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Boundary conditions, loads and couplings. 

 

 Click on File->New and select Simcenter Thermal/Flow (Sim). 

 In the New Simulation dialog box, simply keep the default values and click OK. 

 In the Solution dialog box, select Coupled Thermal-Flow as Analysis Type and click 

OK. 
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5 – Boundary conditions. 

 In the Simulation Navigator , expand (+) the fem1.fem item . 

This item contains the geometry, meshes and associated materials (via the Collectors). 

 Hide the Pipe polygon and its associated 2D collector (uncheck the associated 

checkboxes ). 

 In the Loads and Conditions group, click on the Constraint Type button and 

add a Temperature constraint . 

 In the Temperature dialog box, specify a temperature of 20°C and select the leftmost 

circular face. This will set the input water in the pipe to be at a temperature of 20°C. 

The water will later on be heated as it passes through the pipe. 

 Click OK to validate the constraint. 
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 Now, still in the same dialog box, select Opening as Type and set the Name option to 

Opening.  

 Select the rightmost circular face, opposite to the previous leftmost circular face and 

click OK. 

 In the Loads and Conditions group, 

click on the Simulation Object 

Type button, and then 

on Flow Boundary Condition 

. 

 In the Flow Boundary Condition 

dialog box, select Inlet Flow as 

Type, and set the Name option to 

Inlet. 

 Select as object the same leftmost 

circular face as previously selected, 

and set the Velocity option of the 

Magnitude field to 30 mm/s. 

 Click Apply to validate (keep the 

dialog box open for the next 

boundary condition). 
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6 – Loads. 

 

 Hide the Water and its associated 

3D collector and show the Pipe and 

its associated 2D collector. 

 In the Loads and Conditions group, 

click on the Load Type 

button, and then on 

Thermal Loads . 

 In the Thermal Loads dialog box, 

select Heat Load as Type. 

 Set the Name option to 

Head_Load_1000W. 

 In the Magnitude field, set the 

option Heat Load to 1000 W. This 

will model the heat source that is 

heating the water through the pipe 

(a coupling pipe-water will be 

needed in order to “transport” the 

received heat from the metal of the 

pipe to the water. We will 

implement this coupling later on). 

 As object, select the bottom most 

circular face of the Pipe and click 

OK. 
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7 – Couplings. 

 

We will now couple the 2D mesh of the Pipe with the 3D mesh of the Water. This will 

allow the heat of the Pipe to propagate into the Water. 

 

From now, you will have to hide and show alternatively the Pipe and the Water in 

order to select the correct faces. 

 

 In the Loads and Conditions group, click on the Simulation Object Type  

button, and then on Thermal Coupling . 

 In the Thermal Coupling dialog box, go to the Magnitude field and set the Type option 

to Heat Transfer Coefficient. Set the Coefficient option to 30 W/(m² °C). 

 Select as Primary Region the bottom most circular face of the Pipe (as previously 

done) and as Secondary Region the bottom most circular face of the Water. 

 Click Apply (do not close the dialog box). 
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 In the same dialog box, keep the same parameters. This time, use the left cylinder 

surface of the Pipe as Primary Region and the left cylinder surface of the Water as 

Secondary Region. This coupling will allow setting the pipe to the same temperature 

as the water, as the later enters in the first. 

 Save your simulation files. 



____________________________________________________________________________ 

A&M – CAD in mechanical engineering  Written by Christophe Leblanc 11 

8 – Solving the model. 

 

Now, as all physical parameters (geometry, meshes, associated materials, loads, couplings 

and boundary conditions) are set, we will solve the model and then visualize the different 

results. 

 Click on the Solve   button. Keep the default values in the Solve dialog box and 

simply click OK. The computations should take about a minute. 

 When the Review Result dialog box shows up, click yes. In the Solution Monitor 

dialog box, click on the Graph(s) Convergence button to check if the 

computation indeed converge. 

 You should get a convergence graph similar at the one shown here below. 

 Close the graph window, the Solution Monitor, the information Window and the 

Analysis Job Monitor (Cancel). 
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Visualizing the results. 

 

 Go to the Post Processing Navigator 

. In the tree, expand (+) the 

Solution 1 item, right-click on the 

Thermal Flow item, and select Load in 

the menu. 

 Then, expand (+) the Thermal Flow 

item. 

 

In what follows, we will visualize different 

results, such as the temperature of the pipe, 

the pressure, and the velocity field an 

temperature of the water. 

9 - Visualizing the temperature of the pipe. 

 

 Right-click on the Temperature-Nodal item and select Plot in the menu. You should 

get the temperature of the pipe which varies between 20°C and 254°C. It can be 

observed that the maximal temperature is reached at the bottom circular face of the 

pipe, where the heat load is applied. 
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 10 - Visualizing the temperature of the water. 

 

 Right-click on the Fluid-temperature... item and select Apply. The water temperature 

varies between 20°C and about 67°C. It can be observed that the water temperature at 

the exit side of the pipe (right) is about 35°C. 

11 - Visualizing the water pressure. 

 

 In a similar way as done above, visualize the water pressure. There are three kinds of 

pressures: total pressure (Ptotal), static pressure (Pstatic) and dynamic pressure (Pdynamic). 

 The static pressure (Pstatic) is the pressure applied by a fluid when it is at rest. 

The dynamic pressure (Pdynamic) is the contribution to the total pressure by the movement 

of the fluid:  

 , where  is the fluid density, v its velocity and g = 9,81 m/s². 

 

 The total pressure is given by: Ptotal = Pstatic + Pdynamic. 
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12 - Visualizing the velocity field. 

 

 Right-click on Velocity... and 

select Apply. By default, NX 

shows the magnitude of the 

velocity field, but it is also 

possible to visualize its directions 

and streamlines. 

 In the Post Processing Navigator, 

select the Post View... item and 

right-click on it. In the menu, 

select Edit Post View.  

 In the Post View dialog box, click 

on the Display tab and set the 

Color Display option to Arrows. 

 In the Edges & Faces field, set the 

Edges option to Feature and click 

on Apply to validate (do not close 

the dialog box). 

 You should get the result shown 

below. 
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It is also possible to visualize the 

velocity field inside a given plane. 

 

 At the bottom of the same dialog 

box, set the Display On option to 

Cutting Plane, and click on the 

Options... button. 

 In the Cutting Plane dialog box, 

set the Cut Plane option to 

Absolute Rectangular X.  

 Check the Show Feature Edges 

option and set the Clip Side option 

to Both. 

 Finally, click OK, followed by 

Apply on the Post View Dialog 

box. 

 You should obtain the velocity 

field at the middle of the pipe. 
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We will now visualize the 

streamlines. 

 

 In the Post View dialog box, set 

back the option Display On to 

Volume.  

 Set the Color Display option to 

Streamlines. 

 In the Seedset field, click on the 

Create... button. 

 In the Seed Set dialog box, check 

the Select Nodal Location check 

box, set the Pick option to All on 

Face, and click on select Exterior 

Point. 

 Select the left (inlet) face of the 

pipe. 

 Set the Extract option of the 

Extraction Parameters field to 

Downstream and click OK. 

 In the Post View dialog box, click 

OK. 

 You should get the below result. 
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We will now animate the streamlines with particles. 

 

 Click on the Results tab of the toolbar, and then on the Animate button. 

 In the animation dialog box, set the Animate option to Streamline and click on the 

Play button. 

 You should get particles travelling on the streamlines from the inlet (left) to the 

opening (right). 

 Do not forget to save your files. 


